三联

首页 > 教程 > 电脑教程 > 网络应用教程

路由器需要什么配置

时间:2013-04-28 11:49

   路由器是计算机网络的桥梁,是连接IP网的核心设备。它不仅可以连通不同的网络,还能选择数据传送的路径,并能阻隔非法访问。路由器是工作在OSI参考模型第三层——网络层的数据包转发设备,路由器通过转发数据包来实现网络互连。对初学者来说,路由器的配置并不易。本文以我院选购使用的硬件Cisco 2800路由器为例,探讨利用Console端口进行配置方法。

  1 路由器的基本功能

  1.1 路由器的概念

  所谓“路由[1]”,是指把数据从一个地方传送到另一个地方的行为和动作,是一种连接多个网络或网段的网络设备,路由器是在网络层实现网络互联的设备,路由器依靠转发网络层数据包来实现网络互联。

  1.2 路由器的基本功能

  简单的讲,路由器主要有以下几种功能[1]:第一,网络互连,路由器支持各种局域网和广域网接口,主要用于互连局域网和广域网,实现不同网络互相通信;第二,数据处理,提供包括分组过滤、分组转发、优先级、复用、加密、压缩和防火墙等功能;第三,网络管理,路由器提供包括配置管理、性能管理、容错管理和流量控制等功能。

  2 路由器的配置方式

  路由器可以支持多种方式进行配置[2],本文重点介绍是利用Console端口进行配置以及其口令、接口IP等相关配置方法,用户可以选择适合自身网络连接方式对路由器进行配置:① 利用终端通过Console端口进行本地配置;② 利用异步连接Modem 进行远程配置;③ 通过Telnet方式进行本地或者远程配置;④ 通过TFTP方式进行网络配置;⑤通过Web页面进行配置。

  3 搭建本地配置环境

  以下利用Console端口搭建本地配置环境的介绍,在使用路由器之前,必须对路由器进行相关的配置,于是本文采用通过Console端口方式对路由器进行配置。

  3.1 路由器配置接口

  路由器的配置端口有两个,分别是Console”和“AUX”,“Console”通常是用来进行路由器的基本配置时通过专用连线与计算机连用的,而“AUX”是用于路由器的远程配置连接用的。准备一条微机的串口线通过标准的RS232电缆和路由器的Console端口连接。如图1所示。

路由器需要什么配置 三联

  3.2 配置终端参数

  电缆连接完成之后,进入终端参数配置。首先,在微机上运行终端仿真程序,以Windows系统自带“超级终端”建立新连接,选择实际连接时使用的微机rs232串口,便可设置终端参数进行路由相关配置。

  基本的配置步骤:用鼠标点击开始 --> 所有程序 --> 附件 --> 通讯 --> 超级终端”,选择用于连接的串口设备,系统弹出如图2、图3、图4所示的连接说明界面。

点击查看原图
点击查看原图

  设置终端通信参数为:9600波特、8位数据位、1位停止位、无校验、无流控,选择终端仿真类型vt100,如图5所示。最后单击【确定】按钮就完成了超级终端的设置。

  3.3 启动路由器

  接上电源,路由器启动后即将在终端屏幕上看到自检信息,自检结束后提示用户键入回车,直到出现命令行提示符“Router﹥*****”。

  第一次启动Cisco路由器,进入信息读取模式:

  -------------------------------------

  Cisco Router and Security Device Manager (SDM) is installed on this device. This

  feature requires the one time use, initial credentials, of username "cisco"

  with password "cisco".

  Please change these publicly known initial credentials through SDM or IOS CLI.

  Here's the Cisco IOS command:

  no username cisco

  NOTE: Please add a new username to be able to launch SDM for router management.

  For more information about SDM please follow the instructions in the QUICK

  START GUIDE for your router or at

  http://www.cisco.com/go/sdm

  --------------------------------------

  4 配置Cisco 2800路由器[3]

  4.1 基本命令模式

  这时便可以在终端上查看路由器的运行状态,键入“?”可在线帮助,如Router>? ;

  进行路由器的当前配置:

  Router> enable

  Password:*******

  Router# conf terminal //切换到配置状态

  Router(conf)# enable secret my-root-password //定义超级口令

  Router(conf)# ip host router-sgyy //定义路由器名

  Router(conf)# ip domain-name yourdomain.com //定义所属域名称

  Router(conf)# http server

  Router# show run //显示路由器的当前配置

  Router# show ip route//查路由表

  Router# show ip interface bri //查看连接状态

  4.2 口令配置

  用户可以通过口令控制对路由器的访问,以下是设置访问口令:

  Router> enable

  Router# configure terminal

  Router(config)# line console 0

  Router(config-line)# login

  Router(config-line)# password ******

  Router(config-line)# end

  Router# exit

  密码设置完成后,重新启动路由器时,路由器登录需密码验证访问:

  ^C

  !

  line con 0

  password *******

  login

  line aux 0

  line vty 0 4

  privilege level 15

  password *******

  login

  transport input telnet

  line vty 5 15

  privilege level 15

  password *******

  login

  transport input telnet

  scheduler allocate 20000 1000

  end

  4.3 接口配置

  根据我院需求网络系统要求,配置以太网络接口[3]的IP地址。

  查看以太网接口0的状态 :

  Router> enable

  Password: ******

  Router# show interface Ethernet 0 //显示以太网接口0的状态。

  进入配置模式信息:

  Router> enable//进入特权模式

  Password: //特权用户口令

  Router# configure terminal //进入配置模

  式

  Enter configuration commands

  Router?(config)# interface Ethernet 0//进入外部以太网口配置

  Router?(config-if) # ip address

  192.168.1.1 255.255.255.0 //进入AUI0接口的IP地址配置为192.168.1.1,子网掩码为255.255.255.0。

  5 Cisco 2800路由器接口配置信息

  Cisco 2800路由器作为搭建我院OA服务器和网络安全策略的硬件设备[4],配置Cisco 2800路由器接口信息如下所示:

  Building configuration...

  Current configuration : 2355 bytes

  version 12.3

  service timestamps debug datetime msec

  service timestamps log datetime msec

  no service password-encryption

  hostname Router

  boot-start-marker

  boot-end-marker

  logging buffered 51200 warnings

  enable password ******

  username cisco privilege 15 secret 5 $1$sSWy$k0lsLJFTmyqdIf0xToY05/

  username sgyy privilege 15 secret 5 $1$up6r$XThcUXV.UaJYbQelF3Gke0

  no network-clock-participate aim 0

  no network-clock-participate aim 1

  no aaa new-model

  ip subnet-zero

  ip cef

  ip domain name yourdomain.com

  no ftp-server write-enable

  interface GigabitEthernet0/0

  ip address 192.168.1.1 255.255.255.0

  ip nat inside

  duplex auto

  speed auto

  interface GigabitEthernet0/1

  ip address 10.1.1.1 255.255.255.0

  duplex auto

  speed auto

  interface Serial0/1/0

  ip address 102.105.101.102 255.255.255.240

  ip nat outside

  encapsulation ppp

  !

  ip classless

  ip route 0.0.0.0 0.0.0.0 102.105.101.101

  ip http server

  ip http authentication local

  ip nat pool NATOUT 102.105.101.102 102.105.101.102 netmask 255.255.255.240

  ip nat inside source list 1 pool NATOUT overload

  ip nat inside source static tcp 192.168.1.10 80 102.105.101.102 80 extendable

  ip nat inside source static tcp 192.168.2.10 80 102.105.101.102 8080 extendable

  !

  access-list 1 permit 192.168.0.0 0.0.255.255

  control-plane

  banner login ^C

  6 结论

  综上所述,目前Cisco2800路由器能按照配置文件的内容正确运行。在实际的网络管理中,需要去发现、隔离、解决网络故障,可以运用路由器提供的丰富的监控和调试手段,帮助我们去诊断和解决在使用路由器中碰到的问题,关键的是用来监控发现故障,用网络测试命令来定位和隔离故障。

标签:

经典图文

相关文章

热门文章

返回顶部